WordPress Vulnerability Roundup: January 2021, Part 1

vulnerability roundup

Written by

on

Last Updated on January 13, 2021

New WordPress plugin and theme vulnerabilities were disclosed during the first half of January. This post covers the recent WordPress plugin, theme, and core vulnerabilities and what to do if you run one of the vulnerable plugins or themes on your website.

The WordPress Vulnerability Roundup is divided into three different categories: WordPress core, WordPress plugins, and WordPress themes.

Each vulnerability will have a severity rating of Low, Medium, High, or Critical.

In the January, Part 1 Report

WordPress Core Vulnerabilities

WordPress Plugin Vulnerabilities

1.WP E-Signature – Critical

WP E-Signature versions below 1.5.6.8 have an Unauthenticated Remote Code Execution vulnerability.

UPDATE NOW:
The vulnerability is being actively exploited.

The vulnerability is patched, and you should update to version 1.5.6.8.

2. Newsletter Manager – High

Remove the plugin until a security fix is released.

3. Site Offline – Medium

The vulnerability is patched, and you should update to version 1.4.4.

4. WP Postratings – Medium

The vulnerability is patched, and you should update to version 1.86.1.

5. Custom Global Variables – High

Remove the plugin until a security fix is released.

6. Stripe Payments – Medium

The vulnerability is patched, and you should update to version 2.0.40.

7. Orbit Fox by ThemeIsle – Medium

The vulnerability is patched, and you should update to version 2.10.3.

8. WP Paginate – Medium

The vulnerability is patched, and you should update to version 2.1.4.

9. WP Quick FrontEnd Editor – Medium

Remove the plugin until a security fix is released.

10. LiteSpeed Cache – Low

LiteSpeed Cache versions below 3.6.1 have an Authenticated Stored Cross-Site Scripting vulnerability.

The vulnerability is patched, and you should update to version 3.6.1.

WordPress Theme Vulnerabilities

No new theme vulnerabilities have been disclosed this month.

January Security Tip: Scan Your Websites for Vulnerabilities

60% of website breaches involve vulnerabilities for which a patch was available but not applied. This means having software with known vulnerabilities installed on your site gives hackers the blueprints they need to take over your site.

Every day, it gets harder and harder to keep track of every disclosed WordPress vulnerability. You have to compare that list to the versions of plugins and themes you have installed on your site… and make sure you’re constantly updating.

To solve this problem, the iThemes Security Pro plugin just rolled out a better way to protect your sites against software vulnerabilities, the number one culprit of hacked and compromised WordPress sites.

The new, improved WordPress Security Site Scan powered by iThemes performs automatic checks for known website vulnerabilities and, if a patch is available, iThemes Security Pro will automatically apply the fix for you … so you don’t have to. Whew. that’s some peace of mind. 

Site Scan Vulnerability Details

A WordPress Security Plugin Can Help Secure Your Website

iThemes Security Pro, our WordPress security plugin, offers 50+ ways to secure and protect your website from common WordPress security vulnerabilities. With WordPress, two-factor authentication, brute force protection, strong password enforcement, and more, you can add an extra layer of security to your website.

Get iThemes Security Pro

vulnerability roundup



Source link

X
X